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Carvaan Computer-4

Computer Memory and Storage Devices1

  It is also a highly durable device and keeps the data safe and 
secure. We can rewrite data in it any number of times.

A. 1. (c); 2. (a); 3. (c); 4. (c); 5. (b); 

C. 1. T; 2. F; 3. T; 4. T; 5. F; 

 2.  USB drive or Flash drive : A USB drive, popularly known as 
the pen drive or thumb drive, has emerged at the most 
popular data backup device. It is used for copying and 
moving data from one computer to another. It is a small, 
light-weight, removable and re-writable drive. It is a plug 
and play device that plugs into a computer’s USB port. It 
comes in various storage capacities from 4 GB to 32 GB.

 3.

D. 1. Multimedia Card : Multimedia card is a flash memory card 
used as a storage medium for portable devices like mobiles, 
digital cameras and music players in a form that can easily 
be removed for access by a computer. These devices 
transfer image and music files into a computer using 
multimedia card reader which can be connected to a 
computer through a USB cable. Most of the laptops come 
with in-built card readers.

B. 1. pen drive; 2. Hard disk; 3. internal; 4. bit; 5. 1024; 

RAM
1. RAM stands of “Random 

Access Memory” 
2. RAM is a volatile memory 

that stores the data 
temporarily.

3. The data is lost when a 
computer is switched off.

ROM

 ROM is a non volatile 
memory that store the 
data permanently.

 ROM stands of “Read Only 
memory”

 The data can only be read 
from the ROM and is not 
erasable

1



2

   Secondary Memory

 4. A computer works with only two digits– 0 and 1. The data 
input into the computer are first converted into 0s and 1s 
for the computer to understand. These digits are called 
Binary digits or bits. A bit is the smallest chunk of 
information that a computer can work with.

  A computer language represented in bits is called a binary 
language.

  So,  1 B = 8 bits

  Primary Memory or Main Memory

 5. Computer memory can be of two types :

  The memory of a computer is represented in bytes, where 1 
byte = 8 bits. A byte is denoted by B.

Computer Memory

Primary Memory

RAM Hard disk CD DVD Flash
drive

Blu ray
disc

Memory
card

Secondary Memory

ROM

Repeat Command and Procedures in Logo

A. 1. (c); 2. (a); 3. (b); 4. (a); 5. (a); 

C. 1. T; 2. F; 3. T; 4. F; 5. F; 

 2.  Loading a procedure is like opening a saved file. You can 
execute a procedure only after you load it. 

  Step 1 : Click on the File menu of the MSW Logo Screen. 

  To load a procedure, follow these steps: 
  Step 1 : Click on File. 
  Step 2  : Click on the Load option. 

D. 1. To delete a Procedure in LOGO, follow these steps : 

B. 1. .LGO; 2. END; 3. TO; 4. input box; 5. polygon; 

  Step 3 : Select the Procedure to be deleted and click on the 
OK button. 

  Step 2 : Click on the Erase option. The Erase procedure   
window opens. 
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  Step 3 :  Select the location from which your file is to be 
loaded.

  Step 4 : Click on Open.
  You can also load a procedure by typing LOAD followed by 

double inverted quotes and the   name of the procedure. 
Then press the ENTER key, for example; LOAD “SQUARE”.

 3. To write a procedure using Input Box, follow the steps given 
below: 

  Step 1 :  Click in the Input box. 
  Step 2 :  Type ‘TO’ followed by a single space and the name       

of the procedure. For example; TO SQUARE. Press Enter key. 
Step 3 : To Mode (Cancel to End) Input box will appear. Type 
the set of primitives one after other for making a square. 
Press the Enter key after each line. 

  FD 100

  Any closed figure with three or more sides is called a  
polygon. A polygon in which all the sides are of equal length 

  RT 90
  FD 100

  Step 5  :  To execute the procedure, type the procedure name 
 SQUARE in the Input Box. Press the Enter key. 

  (b) Making polygons using the REPEAT Command 

  Step 4 :  When all the primitives are entered, type in END 
and press the Enter key. The procedure for SQUARE will be    
defined. 

  The square will appear on the MSWLogo Screen .

  FD 100

  FD 100
  RT 90

  RT 90

 4. (a) The REPEAT command tells the turtle to repeat the given 
command a certain number of times. For shapes, such as, a 
square, where the same command is repeated for all the sides, 
the REPEAT command can be useful. 

  RT 90
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is called a regular polygon. The REPEAT command can be 
used to draw regular polygons. 

  3. End line

 5. A LOGO procedure is a set of LOGO commands that are 
executed one after the other to carry out a specific task.

  1. Title of the procedure.
  2. Set of instructions.

  The REPEAT command for a polygon with n number of sides     
is written as follows: 

  A LOGO procedure is divided into three parts–

  REPEAT n [FD (number of steps) RT 360/n]

Using Windows 10 Operating System3

B. 1. folder; 2. Desktop; 3. Microsoft Edge; 4. transparent; 
5. Software; 

   A shortcut icon of Word 2016  ...  appears on the desktop 
with a jump arrow in its lower left corner.

A. 1. (c); 2. (c); 3. (b); 4. (b); 

C. 1. F; 2. F; 3. F; 4. T; 5. T; 

D. 1.  Click on the Start button ...  and select All Apps. Select the 
Word 2016 program.

   Drag the icon to the Desktop.

 2.

   Double-click on the shortcut icon to open the application 
directly.

Files

2. As we keep important 
papers in a fill, likewise 
any information in a 
computer is a saved in the 
form of a file.

1. It is a collection of related 
information stored 
together on some storage 
device.

Folders
 A folder can held other 

folders as well.

 As we keep all our files in a 
file cabinet, similarly a 
folder in a computer is like 
a cabinet where we keep 
relevant files.
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 3.  Right-click on the blank area of the desktop.
   A shortcut menu appears.

   Type a name for the folder and press the Enter key.
 4. This PC icon replaces the My Computer icon in Windows 8. 

It contains all the drives and folders.
 5. Attractive and Easy To Use

   Click on the Folder option. A new folder icon will be 
displayed on the desktop with its default name i.e, ‘New 
Folder’.

  Improved Start Menu

   Place the pointer on the New option. A list of sub-
options appears, which is called Cascading Menu.

  Windows 10 has a very attractive transparent look with blue 
highlighting features. It has a complete set of new pictures, 
themes, tiles, and icons. The use of graphics makes it quite 
interactive. It works the way we want and makes new things 
possible.

  The new Start menu of Windows 10 gives you quick access 
to Apps and services. In the left pane, you can find File 
Explorer, Settings, and a list of the most used Apps, Power 
option etc. The ‘All Apps’ option at the bottom of the left 
pane displays all the Apps and programs. In the right pane, 
live tiles are displayed which consist of various  Apps.

Editing in MS Word 20164

A. 1. (c); 2. (b); 3. (c); 4. (a); 5. (b); 

C. 1. T; 2. F; 3. T; 4. T; 5. F; 

D. 1. Thesaurus helps us to improve our vocabulary by providing 
a list of synonyms (words with similar meaning), and 
antonyms (words with opposite meaning) for any word. 

 2. The Undo command is used to reverse the last command. 
The Redo command is used to reverse the Undo action.

 3. We correct a spelling error using thesaurus.

B. 1. Undo; 2. copy; 3. double-click; 4. editing; 5. Ctrl + A; 
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  Follow these steps to use Thesaurus :

   Select the word for which you want to find synonyms or 
antonyms.

   Click on the Review tab. Select the Thesaurus option in 
the Proofing group.

   The Thesaurus tasks pane opens, displaying the 
synonyms and antonyms.

 4. For coping (or moving) and pasting text, follow these steps :

   Move the mouse pointer to the suitable word, click on 
the  drop-down button present on its right side and 
select the Insert option. The existing word will be 
replaced with the selected one.

  Step 5 : In the Clipboard group, click Paste.

  Step 3 : In the Clipboard group, click Copy (or Cut).

  (c) An entire document  T riple-click the selection bar or press 
Ctrl + A.

  Step 1 : Select the text to be copied.

  Step 2 : Click the Home tab (if it is not already selected).

  (a) A line of text  Click the selection bar to the left of      
the line.

 5. The selection bar is the space between the left edge of the 
page  and where the text begins. 

  Step 4 : Position  the cursor at the location where you want    
to paste the text.

  (b) A paragraph Double-click the selection bar or 
triple-click anywhere in    the paragraph.

Formatting in MS Word 20165

A. 1. (c); 2. (b); 3. (b); 4. (b); 5. (b); 

C. 1. T; 2. T; 3. F; 4. F; 5. T; 

B. 1. five; 2. Paragraph; 3. Formatting; 4. Font; 5. Font color; 

D. 1. Format Painter is used when you want to copy formatting 
from one item to another. For graphics, the format painter. 
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 2. (a) The way in which you place the text in your document is 
called alignment.

               numbered lists

  There are four types of alignment.

  These features are used to emphasize and draw attention 
towards some important information: 

  Step 2 : Click on the Bold button       in the Font group. The     
 text will become bold (thick).

Works best with drawing objects, such as Autoshapes.

  3.  Center  4.  Justify

  1.  Align Text left   2.  Align Text Right

 3. The different change will option available in MS Word 2016 
are follows :

  (a)  Changing font and its size  Highlighting certain 
words

  We can apply different colours to the text. The steps to 
colour the text are :

  Step 1 : Select the text to change the font colour.

  (b) Changing Font Colour

   Changing text caste  Applying border

  Step 3 : Click the drop down list arrow on Font Color button              

                   in Font group. colour palette appears.

  Step 4 : Choose the desired colour from the palette and click 
it to apply.

  Step 2 : Click the Home tab.

  Bold, Italic and Underline

  Step 1 : Select the text.

  Step 3 : Click on the Italic button      after selecting the text. 
The text appears slanting to the right.

  Step 4 : Click on the Underline button     to place a line 
under the text. 



  Step 5 : Click on the Strikethrough button        to cross out 
the text by drawing a line through it.

 4. (a) Font is a set of letters, numbers of symbols with the      
same style  and size.

  (b) To change the font of the text and its size, follow the 
given steps :

  Step 1 :   Select the text to change the font .
  Step 2 : Click the Home tab.
  Step 3 : Click the drop-down list arrow       on the Font   

button                           from the Font group.

  Step 6 : Choose the desired Font Size from the list and click 
it to apply.

 5. Formatting means changing the appearance of document in 
order to make it attractive.

  Step 4 : Choose the desired font from the list and click it to 
apply.

  Step 5 : Now click the drop down list allow on the Font Size  
button              in the Font group.
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Introduction to MS PowerPoint 20166

A. 1. (b); 2. (c); 3. (c); 4. (c); 5. (a); 

  Step 1 : Click on the Save button    present on the Quick     
Access Toolbar or select the File tab > Save option. Click on 
Browse button. The Save As dialog box appears.

 2. Microsoft PowerPoint provides the option of combining all 
the slides of a presentation into a slide show. It is just like 
the pictures in a photo album. It displays all the slides in  
presentation one by one on the screen.

B. 1. .pptx; 2. F5; 3. Placeholder; 4. Title bar; 5. slides; 

D. 1.  Follow these steps to save a presentation :
C. 1. T; 2. F; 3. T; 4. T; 5. F; 

  Step 3 : The presentation will be saved with the name My 
Presentation and with and extension. pptx.

  Step 2 : Specify the name, ‘My Presentation’ in the File 
name text box. Click on the Save button.
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   Click on the drop-down arrow next to the New Slide 
button      in the Slides group on the Home tab.

   Click on the desired layout.
   PowerPoint will add a new slide, with the selected layout 

in the center of the PowerPoint window. The new slide 
can also be seen in the ‘Slides tab’ on the left.

 3.  Whenever we add a new slide in our presentation, we must 
select its layout first.

   Teachers can use presentations to prepare their lesson 
plans.

   A list of available slide layouts will be displayed.

 4.  A presentation is helpful to us in many ways :
   Using PowerPoint, we can make projects on any topic.

   People of the business world can use it to present 
information about their products or company in 
seminars and meetings.

 5. Placeholder is the dotted rectangular box where text, 
pictures, and graphs are placed.

   Open an existing presentation, e.g., My Presentation. 

The Magic of Artificial Intelligence (AI)7

A. 1. (b); 2. (b); 3. (b); 4. (c); 5. (b); 

B. 1. T; 2. F; 3. T; 4. T; 5. F;

 3. Narrow AI is a type of AI that is good at doing one specific 
task. It can do that task very well, but it cannot do anything 
else. It is like a robot that only knows how to clean or a 
computer that only knows how to play chess.

D. 1. Artificial Intelligence; 2. Narrow; 3. recommend; 4. diseases; 
5. smarter; 

D. 1. AI helps some cars drive by themselves. These cars have 
special computers that make decisions, like when to stop or 
turn.

 2. Recommendation system like YouTube suggest videos using                                                                                  
AI based on what you watched before.
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    General AI is a type of AI that can think and learn like a 
human. It can do many different things, just like we can. It 
can solve problems, make decisions, and even learn new 
things by itself.

 4.  Doctors use AI to look at X-rays and find diseases.

 5.    AI is very smart, but it is not exactly like a human brain. It 
can do things faster and remember more, but it only knows 
what people teach t. It cannot think or feel emotions like we 
do. That’s why humans and AI work together. 

E. 1. (b); 2. (d); 3. (a); 4. (c); 5. (e);

The Internet Web Browser 8

  3. Telephone Line  4. Web Browser
  1. Modem   2. An Internet Connection

A. 1. (c); 2. (b); 3. (a); 4. (b); 5. (b); 

B. 1. browser; 2. www; 3. bps; 4. e-commerce; 5. Internet; 

C. 1. T; 2. T; 3. F; 4. T; 5. F; 

D. 1.

 2.

 4. Some uses of the Internet are a follows :

 

 
 3. Some basic requirements of Internet connection–

2. A web page is a document 
that is suitable for the 
world wide web and web 
browsers.

Web Page
1. A Webpage is any page on 

the Internet which links to 
other pages.

 A homepage is the “Front” 
page for a website, 
typically named index. htm 
or index. html. The page 
loaded by default when 
the browser searches for a 
site. 

Home Page

1. It is a software application 
or program that allow 
 you to access the entire 
information available on 
the web.

 Some web browsers are 
Mozila Firebox, Opera etc.

Web Browser Search Engine
 A search engine is a 

software system that 
searches the web pages for 
information on a particular 
topic. 

 Some search engines are 
Google, Yahoo, and Bing. 
etc.
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  (iii) The internet is being used by various companies to 
advertise and sell their products. You can buy and sell 
various products over the Internet. This type of internet 
activity is called e-commerce.

  (i)  You can search and access any information based on any 
topic on the Internet.

  (ii)  With the internet, communication is a lot easier. You can 
send emails, do video conferencing, chat with your 
friends on social networking sites, and so on.

  (iv) You can use the Internet for your entertainment as well 
for various activities, such as playing online games, 
watching movies, and listening to music.

  (vi) Internet banking is one of the most important aspects of 
the Internet. It lets you pay bills, operate your bank 
accounts from anywhere, book railways and air tickets, 
and do various other transactions.

 5. The term ‘Internet’ means an international network of  
computers. 

  (v) The Internet can be used for education as well. There are 
several online courses available on the Internet.

Google Docs

  Select All Matching text, Header and footer, Document 
Outline, Research Tool, Voice Typing, Share Document with 
Others.

B. 1. T; 2. F; 3. T; 4. F; 5. T

C. 1. Google workspace; 2. share; 3. Font; 4. Google Drive

 5. collaboratively

D. 1. Some Additional Features in Google Docs.

 2. Once you are done with editing, you can share your 
document  with others by clicking on the share        button           
present on the upper right corner of the screen.

A. 1. (b); 2. (b); 3. (c); 4. (b); 5. (a) 

on the right side of the ribbon.



D. 1. Format Painter option help us to apply the same formatting 
features to some portion of the text. We can copy the 
formatting features.

  Step 1 : Select the text to be copied.

  Step 3 : In the Clipboard group, click Copy (or Cut).

A. 1. (c); 2. (c); 3. (c); 4. (c); 5. (a); 6. (b) 

B. 1. Home tab; 2. ctrl + Z; 3. click; 4. folder; 5. pendrive; 6. 1024;  

C. 1. T; 2. F; 3. T; 4. T; 5. T; 6. F 

 2. Formatting means changing the appearance of a document 
in order to make it attractive. 

 3. For coping (or moving) and pasting text, follow these steps :

  Step 2 : Click the Home tab (if it is not already selected).

  Step 4 : Position  the cursor at the location where you want    
to paste the text.
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Periodic Test Paper-1

  Step 3.     Choose an option (upload, Drive, Web, Camera, etc.)

 3. This option is selected by default which allows multiple 
people to work on the same project in real time. When you 
share a document with people, they receive an email. It 
contains the link to the shared document, which allows 
them to edit it along with other users. Each editor  who is 
working in the document will be visible as icons at the top 
right corner of the screen.

  Step 2.   Click Insert > Image.

 4. Google Docs automatically saves your work in Google Drive.

E. 1. (e); 2. (c); 3. (a); 4. (b); 5. (d) 

 5. To add an image to a Google Docs document.

want to collaborate on the document.    

  Step 1. Open Google Docs and your document.

  Step 4. Select the image and insert it into the document.



D. 1. To write a procedure using Input Box, follow the steps given 
below: 

Step 2  : Type ‘TO’ followed by a single space and the name of 

A. 1. (a); 2. (a); 3. (b); 4. (b); 5. (c); 6. (a) 
B. 1. Logo; 2. bps; 3. e-commerce; 4. Pen; 5. Scratch; 6. Title bar;  
C. 1. F; 2. T; 3. T; 4. F; 5. F; 6. T 

Step 1  : Click in the Input box. 

Periodic Test Paper-2

 5. Two features of window 10.

 4. Creating a Folder

F. Do it yourself.

 6. 

  1.  It Supports multiple desktop of attractive and easy to use.

  A short menu appears.

  Step 5 : In the Clipboard group, click paste.

  2. Searching made easier with tool cortana.

  Right   click on the blank area of the dark top.

  Click the folder option. A new Folder icon will be 
displaced on the desktop with its defeat  name i.e. 'New 
Folder'.

E. Do it yourself.

  Place the pointer on the New option. A list of Sub-option 
appears which is called cascading menu.

   Type a name for the folder and paste the center key.   

RAM
1. RAM stands of “Random 

Access Memory” 
2. RAM is a volatile memory 

that stores the data 
temporarily.

3. The data is lost when a 
computer is switched off.

ROM
 ROM stands of “Read Only 

memory”
 ROM is a non volatile 

memory that store the 
data permanently.

 The data can only be read 
from the ROM and is not 
erasable
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             the procedure. ; TO SQUARE. Press Enter key. For example

              FD 100
              RT 90
              FD 100
              RT 90
  FD 100
              RT 90
              FD 100

Step 4  : When all the primitives are entered, type in END and 
press the Enter key. The procedure for SQUARE will be 
defined. 

Step 3  : The To Mode (Cancel to End) Input box will appear. Type 
the set of primitives one after other for making a 
square. Press the Enter key after each line. 

              RT 90

Step 5  : To execute the procedure, type the procedure name 
SQUARE in the Input Box. Press the Enter key. 

              The square will appear on the MSWLogo Screen.
 2. Basic Requirement for an Internet Connection.

 6. It is the dotted Rectangular box where text Picture, and 
graphs are placed.

  1. Modem 2. An Internet Connection 3. Telephone Lines 
4. Web Browser 5. Software

 3. The Word 'Internet' is a Combination of two words 
'inter+net' meaning network of networks. It is a word wide 
system of computer network in which users working on 
computers can get information from any other computer.

E. Do it yourself.

 4. A sprite is a graphic element that performs different 
functions based on the commands.

 5. Microsoft PowerPoint Provides the options of Combining all 
the Slides of a Presentation into a Slide Show. It is first like 
the pictures in a photo album.
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